Visit Us on Facebook!
Follow us on Twitter!
Read Our Blog!
Procare Technical Support...
Help is Only a Click Away!
800-964-1729
Mon.-Fri. 6:00 am - 4:00 pm PST
HomeResourcesResourcesVideosVideosWebinarsFAQsLearn ProcareTrainingForumProcare SiteContact
 

Downloads

Remote Assistance

Patches

Required Before Installation

One or both of these Microsoft items MUST be installed BEFORE you install a download of Procare (not needed if you're installing from CD).
  What? Required for:
1. Windows Installer 4.5 Redistributable
Windows XP/Vista/Server2008
2. Microsoft .NET Framework 4 (Web Installer)
Windows XP/Vista/Windows 7/Server2008

Data Hosting

Drivers

Procare Extras

Special Reports